[Coquelicot] Installation

Garreau Alexandre galex-713 at galex-713.eu
Sun Jul 7 13:25:08 CEST 2013

Le samedi 06 juillet 2013 à 22:19 +0200, Lunar a écrit : 
> Garreau Alexandre:
> > As I've said, I use Debian GNU/Linux Wheezy on my server.
> > I've installed ruby-dev, but that didn't fixed the problem: same error.
> Buildig nokogiri requires libxml2-dev and libxslt-dev. Installing those
> two packages should fix the issue. At least it did in a fresh live
> Wheezy system.
> I have updated the INSTALL documentation accordingly, thanks for the
> report.

Good :)

But, even installing libxml2-dev and libxslt-dev, it still doesn't
work :/

        root at server-713:/var/www/coquelicot# bundle install --deployment
        Fetching gem metadata from https://rubygems.org/.........
        Fetching gem metadata from https://rubygems.org/..
        Installing rake (10.0.3) 
        Installing activesupport (3.0.0) 
        Installing active_support (3.0.0) 
        Installing backports (3.1.0) 
        Installing mime-types (1.17.2) 
        Installing nokogiri (1.5.0) 
        Gem::Installer::ExtensionBuildError: ERROR: Failed to build gem
        native extension.
                /usr/bin/ruby1.9.1 extconf.rb 
        extconf.rb:10: Use RbConfig instead of obsolete and deprecated
        checking for libxml/parser.h... yes
        checking for libxslt/xslt.h... yes
        checking for libexslt/exslt.h... yes
        checking for iconv_open() in iconv.h... yes
        checking for xmlParseDoc() in -lxml2... yes
        checking for xsltParseStylesheetDoc() in -lxslt... yes
        checking for exsltFuncRegister() in -lexslt... yes
        checking for xmlHasFeature()... yes
        checking for xmlFirstElementChild()... yes
        checking for xmlRelaxNGSetParserStructuredErrors()... yes
        checking for xmlRelaxNGSetParserStructuredErrors()... yes
        checking for xmlRelaxNGSetValidStructuredErrors()... yes
        checking for xmlSchemaSetValidStructuredErrors()... yes
        checking for xmlSchemaSetParserStructuredErrors()... yes
        creating Makefile
        compiling html_element_description.c
        html_element_description.c: In function ‘get_description’:
        html_element_description.c:249:10: warning: cast discards
        ‘__attribute__((const))’ qualifier from pointer target type
        compiling xml_sax_parser_context.c
        compiling xml_element_content.c
        compiling xml_comment.c
        compiling xml_processing_instruction.c
        compiling xml_element_decl.c
        compiling xml_encoding_handler.c
        compiling xslt_stylesheet.c
        compiling html_sax_parser_context.c
        compiling xml_document.c
        compiling xml_entity_reference.c
        compiling xml_libxml2_hacks.c
        compiling xml_schema.c
        compiling xml_relax_ng.c
        compiling xml_text.c
        compiling xml_sax_push_parser.c
        compiling xml_namespace.c
        xml_namespace.c: In function ‘prefix’:
        xml_namespace.c:14:13: warning: variable ‘doc’ set but not used
        xml_namespace.c: In function ‘href’:
        xml_namespace.c:33:13: warning: variable ‘doc’ set but not used
        compiling html_entity_lookup.c
        compiling xml_entity_decl.c
        compiling xml_reader.c
        compiling xml_document_fragment.c
        compiling xml_xpath_context.c
        xml_xpath_context.c: In function
        xml_xpath_context.c:184:3: error: format not a string literal
        and no format arguments [-Werror=format-security]
        cc1: some warnings being treated as errors
        make: *** [xml_xpath_context.o] Erreur 1
        Gem files will remain installed
        in /srv/www/coquelicot/vendor/bundle/ruby/1.9.1/gems/nokogiri-1.5.0 for inspection.
        Results logged
        to /srv/www/coquelicot/vendor/bundle/ruby/1.9.1/gems/nokogiri-1.5.0/ext/nokogiri/gem_make.out
        An error occurred while installing nokogiri (1.5.0), and Bundler
        Make sure that `gem install nokogiri -v '1.5.0'` succeeds before
        root at server-713:/var/www/coquelicot# 

Compilation errors…
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 836 bytes
Desc: This is a digitally signed message part
URL: <http://listes.potager.org/pipermail/coquelicot/attachments/20130707/e486445c/attachment.pgp>

More information about the Coquelicot mailing list