[Coquelicot] configuration problem: it works via http, but not https

Gijs Hillenius gijs at hillenius.net
Wed Apr 4 09:38:58 CEST 2018

On  4 Apr 2018, Lunar wrote:

Hello, and thanks for the responses

> Hi Gijs,
> Gijs Hillenius:
>> On a Debian stable server, I installed Coquelicot and followed
>> /usr/share/doc/coquelicot/README.Debian
>> For some reason, this install will let me use Coquelicot via http,
>> but not https. I don't mind too much for the upload part (perhaps I
>> should), but I would like the download url to work via https
>> When trying to access the upload service via https, Firefox will
>> warn: ssl3_get_record:wrong version number, and Chromium says:
>> I see nothing in the server logs that helps me.
>> Anybody have any ideas?
> Have you run `a2enmod ssl proxy_http headers`?
> This sounds like the `ssl` module is not enabled.

both modules are enabled. 

What I've tried - without the desired effect - is pointing to the
LetsEncryt SSLCertificateFile and SSLCertificateKeyFile, that gives the
same error.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 832 bytes
Desc: not available
URL: <http://listes.potager.org/pipermail/coquelicot/attachments/20180404/9d2cccf3/attachment.sig>

More information about the Coquelicot mailing list